
4 Painting and Editing

Adobe Photoshop allows you to do more 

than edit, enhance, or modify photo-

graphic images. You can also create 

graphics by painting and drawing. 

This lesson focusses on painting. You’ll 

learn how to paint colors with soft edges 

and transitions, and then apply layer 

styles and filters to modify the layer’s 

image data.
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In this lesson, you’ll learn how to do the following:

• Use the basic painting tools and experiment with different options for each tool.

• Work with colors, gradients, or patterns in a layer.

• Use layers to paint, adjust, add effects, and make color changes to specific portions of 

the image.

• Set the blending mode and opacity of a layer to adjust how colors and each element of 

the image combine with the others.

• Set the blending mode and opacity of a painting tool to adjust how a paint stroke 

combines with other pixels in the image.

• Use the eraser tool, history paint brush, and History palette to make corrections.

• Use a pattern from a different image to create a border.

• Create custom brushes and settings that appear in the tool options bar for any 

painting tool.

This lesson will take about 60 minutes to complete. The lesson is designed to be done in 

Adobe Photoshop. 

If needed, remove the previous lesson folder from your hard drive, and copy the Lesson04 

folder onto it. As you work on this lesson, you’ll overwrite the start files. If you need to 

restore the start files, copy them from the Adobe Photoshop Classroom in a Book CD.

Note: Windows users need to unlock the lesson files before using them. For more information, 

see “Copying the Classroom in a Book files” on page 3.

Getting started
Before beginning this lesson, restore the default application settings for Adobe 

Photoshop. See “Restoring default preferences” on page 4. 

You’ll start the lesson by viewing the final Lesson file to see what you’ll accomplish. 

1 Start Adobe Photoshop.

If a notice appears asking whether you want to customize your color settings, click No.
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Choose File > Open, and open the file 04End.psd from the Lessons/Lesson04 folder.

 

3

 

When you have finished viewing the file, either leave the 04End.psd file open for 

reference or close it without saving changes.

 For an illustration of the finished artwork for this lesson, see the gallery at the 

beginning of the color section.

 

Filling the background layer with color

 

Throughout this lesson, you’ll have the opportunity to use a variety of painting tools. 

First, you’ll use the paint bucket tool to paint the background of the image with a light 

green color. The paint bucket tool fills a selection or a layer with the foreground color, 

the background color, or a pattern.

 

1

 

Choose File > Open, and open the file 04Start.psd from the Lessons/Lesson04 folder.

 

2

 

If the Layers palette is not showing, choose Window > Show Layers to display it.

There are nine layers in the Layers palette. Each layer allows you to paint, add an effect, 

or make color changes to specific portions of the entire image.

 

3

 

In the Layers palette, select the Background layer.

 

4

 

If guides are showing in the document window, choose View > Show Extras or View > 

Show > Guides to hide them for now. You’ll be using these guides at the end of this lesson.

 

5

 

If the Color palette is not showing, choose Window > Show Color to display it.

 

6

 

Make sure that RGB Sliders is selected in the Color palette menu.
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7 In the Color palette, enter 182 in the R text box, 201 in the G text box, and 139 in the 

B text box.

Notice that the light green color you specified in the Color palette is now the foreground 

color.

8 Select the paint bucket tool ( ), hidden under the gradient tool ( ).

9 Click inside the image with the paint bucket tool to fill the Background layer with the 

current fill color.

10 Choose File > Save to save your work.

Blending the lily image with the background
The blending mode controls how pixels in an image are affected by painting and editing 

tools. It’s helpful to think in terms of the following types of colors when visualizing a 

blending mode’s effect:

• The base color is the original color in the image.

• The blend color is the color being applied with the painting or editing tool.

• The result color is the color resulting from the blend.

Throughout this lesson, you will learn how to specify a blending mode for a layer in the 

Layers palette and for a tool in the tool options bar. 

For complete information on the blending modes, see “Selecting a blending mode” 

in Photoshop 6.0 online Help.
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You’ll use the Multiply blending mode to blend the white background of the Lily Image 

layer with the green background of the Background layer.

1 In the Layers palette, select the Lily Image layer.

2 Choose Blending Options from the Layers palette menu to open the Layer Style 

dialog box. 

Choosing a blending mode option in the Layer Style dialog box Choosing a blending
mode option in the 
Layers palette

Double-clicking the layer in the Layers palette will also open the Layer Style dialog box.

Setting layer blending options

The blending options in the Layer Style dialog box (Photoshop) and the Layer Options palette (ImageReady) 

let you change a layer’s opacity and blending with the pixels underneath.

Keep in mind that a layer’s opacity and blending mode interact with the opacity and mode of the tools you 

use to paint and edit the pixels on the layer. For example, suppose you are working on a layer that uses the 

Dissolve mode and an opacity of 50%. If you paint on this layer using the paintbrush tool set to Normal mode 

with an opacity of 100%, the paint will appear in Dissolve mode with a 50% opacity because this is the 

maximum the layer can display. On the other hand, suppose you are working on a layer created using Normal 

mode and 100% opacity. If you use the eraser tool with an opacity of 50%, only 50% of the paint will 

disappear as you erase.

–From Adobe Photoshop 6.0 online Help
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3 In the Layer Style dialog box, select Preview, then choose different options from the 

Blend Mode menu and observe the effect that they have on the image. (You may need to 

move the dialog box to see the image better.)

Note: You can also choose a Blend Mode option and enter the Opacity at the top of the Layers 

palette.

4 Choose Multiply from the Blend Mode menu and click OK to close the Layer Style 

dialog box.

The Lily Image layer with the Normal The Lily Image layer with the Multiply 
blending mode blending mode

The Multiply blending mode looks at the color information in each channel and multi-

plies the original color in the image by the color being applied. The resulting color is 

always darker. Multiplying any color with black produces black. Multiplying any color 

with white leaves the color unchanged. When you’re painting with a color other than 

black or white, successive strokes with a layer set to the Multiply blending mode produce 

progressively darker colors. 

Note: You’ll learn about channels in the next lesson. For more information on channels, 

see Photoshop 6.0 online Help.

5 Choose File > Save.
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Painting the petals of the flowers
Now that you’ve seen how the paint bucket tool can fill a layer with color, you’ll use the 

paintbrush tool to apply color with brush strokes.

1 In the Layers palette, select the Flower layer.

2 Click the Switch Foreground and Background Colors icon ( ) so that the foreground 

fill color is white and the background fill color is green.

3 Select the paintbrush tool ( ).

When you select the paintbrush tool, the options change in the tool options bar to corre-

spond with the paintbrush.

4 In the tool options bar, click the Brush arrow ( ) to display a palette of brush sizes, 

and select the Hard Round 5 Pixels brush size.

5 Enter 75% in the Opacity text box for the brush strokes.

6 In the tool options bar, click the Brush Dynamics button ( ) to display the Brush 

Dynamics pop-up palette. Choose Fade from the Opacity menu, and enter 50 in the Steps 

text box.
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The greater the number of steps you enter, the longer it takes for the brush stroke to fade 

away.

Brush stroke set to fade out to 10 steps 50 steps
0% opacity after a specified 
number of steps

7 In the document window, use the paintbrush tool to apply a few strokes to a flower 

petal.

Notice that the white color of each stroke starts at 75% opacity and then fades out 

completely. An easy way to change the size of your strokes while you’re painting is to press 

the [ key to make the brush size smaller or the ] key to make it larger.

8 Now paint all the flowers in the image white, changing the brush size and other 

paintbrush tool options as desired.

Note: You can change the brush appearance on the screen by choosing Edit > Preferences > 

Display & Cursors. For Painting Cursors, select Standard ( ), Precise ( ), or Brush 

Size ( ).

The Brush Size pointer becomes larger when you
press the ] key.

9 Choose File > Save.
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Correcting your work
As you work on an image, you may want to undo an operation or correct a mistake. 

There are many ways to correct mistakes in Adobe Photoshop. In the following sections, 

you’ll use the History palette, eraser tool, and history brush tools to revert your image to 

an earlier state.

Using the History palette

You can use the History palette to revert to a previous state of an image, to delete an 

image’s states, and in Adobe Photoshop, to create a document from a state or snapshot.

1 Paint a few strokes with the paintbrush above the flowers in the image.

2 If the History palette is not showing, choose Window > History to display it.

Each stroke that you painted with the paintbrush is listed as a state in the History palette 

with the most recent state listed at the bottom.

3 In the History palette, select the Paintbrush state above the most recent state (at the 

bottom).

Notice that the last stroke you painted disappears in the image. You can select different 

Paintbrush states to step forward or backward in the history of the image. 

For more information about the History palette, see Photoshop 6.0 online Help.
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Using the eraser tool

The eraser tool changes pixels in the image as you drag through them. If you’re working 

in the background or in a layer with transparency locked, the pixels change to the 

background color; otherwise, the pixels are erased to transparency. You can also use the 

eraser to return the affected area to a state selected in the History palette.

1 Select the eraser tool ( ).

Options for the eraser tool appear in the tool options bar.

2 Drag the eraser tool over one of your paintbrush strokes.

Notice that an Eraser state is added to the History palette.

State of the eraser tool in Paintbrush mode added to the History palette.

3 In the tool options bar, choose a Brush size for the eraser, and enter a value of about 

10% to 20% for the opacity.

The reduced opacity of the eraser tool produces a subtle effect when applying the tool.

You can also change the mode of the eraser from Paintbrush mode to Airbrush, Pencil, 

or Block mode. Changing to a different tool mode allows the eraser tool to erase using the 

attributes of the specified tool.

4 Drag the eraser tool over another paintbrush stroke.

Notice that the eraser tool softens the paintbrush stroke.

5 In the History palette, select the last state that you want to continue with.

6 Choose File > Save.
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Using the history tools

The history tools paint strokes based on the selected state or snapshot in the History 

palette. In this section, you’ll work with both history tools—the art history brush tool and 

the history brush tool. 

The art history brush tool paints with a stylized stroke simulating the look of different 

paint styles.

1 In the History palette, click the Create New Snapshot button ( ).

A snapshot state appears at the top of the History palette.

2 In the Layers palette, select the Lily Image layer.

3 Select the art history brush tool ( ) hidden under the history brush tool ( ).

4 In the tool options bar, choose a small brush size (such as Hard Round 3 Pixels) and 

choose an option from the Style menu (such as Tight Long).

5 Using the art history brush tool, paint over the dark lines of the flowers and leaves. 

You can also experiment with just clicking on an area rather than dragging.
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6 Choose a different style in the tool options bar and paint some more.

Before and after painting with the art history brush tool

The history brush tool paints a copy of the selected state or snapshot into the current 

image window. You’ll use the history brush tool to remove the strokes you made with the 

art history brush tool—without affecting the original dark lines of the Lily Image layer. 

You’ll also set the source for the history brush to be the snapshot you created at the 

beginning of this section.

7 Click in the empty box at the left of the Snapshot 1 thumbnail.

An icon ( ) appears in the box, indicating that each stroke you make with the history 

brush tool will remove a state from the History palette that occurred after Snapshot 1 was 

created.

8 Select the history brush tool ( ) and drag over the areas in the image that you painted 

with the art history brush tool.

Notice that the strokes you make with the history brush tool remove the strokes that you 

made with the art history brush tool and uncover the original dark lines of the image.
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9 In the History palette, select the snapshot state that you created earlier.

10 Choose File > Save.

Smoothing the edges of a paintbrush stroke
Now you’ll learn how to use the smudge tool to soften the edges of your paint strokes. 

The smudge tool simulates the actions of dragging a finger through wet paint. The tool 

picks up color where the stroke begins and pushes it in the direction you drag. 

1 In the Layers palette, make sure the Flower layer is selected. (It was selected in the 

snapshot state you created.)

2 Select the paintbrush tool ( ).

3 In the tool options bar, click the Brush Dynamics button ( ) and choose Off from the 

Opacity menu.

4 Paint a few strokes on the flower petals.

5 Select the smudge tool ( ) hidden under the blur tool ( ).

6 Using the smudge tool, drag over your paintbrush strokes to smooth out their edges.

Before and after using the smudge tool

You can also use the smudge tool to create new strokes by selecting the Finger Painting 

option in the tool options bar.

7 In the History palette, select the Snapshot 1 state of the image.

8 Choose File > Save.
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Creating a subtle overlay effect
Now you’ll finish painting the flowers and apply the Overlay blending mode to the Flower 

layer that blends the color pixels of the flowers with the underlying pixels in the image to 

create a subtle overlay effect.

The Overlay blending mode multiplies or screens the colors, depending on the base color. 

Patterns or colors overlay the existing pixels while preserving the highlights and shadows 

of the base color. The base color is not replaced but is mixed with the blend color to reflect 

the lightness or darkness of the original color. 

1 In the Color palette, select a yellow color for the foreground fill color.

2 Select the paintbrush tool ( ) and paint the flower pistils yellow.

3 In the Layers palette, double-click the Flower layer to display the Layer Style dialog box. 

Position the dialog box so you can see it and the image at the same time.

4 In the Layer Style dialog box, choose Overlay from the Blend Mode menu, and 

enter 70% in the Opacity text box. Then click OK.

5 Choose File > Save.

Painting shadows in nontransparent areas
In this part of the lesson, you’ll lock transparency on the Leaf layer to restrict your 

painting so you can only add shadows to colored pixels on the leaves and not to any trans-

parent pixels between them.

1 In the Layers palette, select the Leaf layer.

2 In the Color palette, select a dark green color.

3 Use the paintbrush tool ( ) to paint a long stroke across several of the leaves.

Notice how your paintbrush stroke applies the dark green color everywhere it touches.

4 Choose Edit > Undo Paintbrush.
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5 At the top of the Layers palette, click the Lock check box next to the Transparency 

icon ( ) to lock transparency for the selected Leaf layer.

6 Paint another long stroke across the leaves.

Notice how your paintbrush stroke does not apply the dark green color to transparent 

areas between the leaves.

Original image Paint stroke on unlocked Paint stroke on locked
layer transparency layer

7 Choose Edit > Undo Paintbrush again.

8 Now, with the Leaf layer’s transparency locked, paint dark green shadows behind the 

flowers and the leaves. (We used a Hard Round 5 Pixels brush. See the end file 04End.psd 

for comparison.)

9 In the Layers palette, enter 80% in the Opacity text box to decrease the opacity of the 

selected Leaf layer.

10 Choose File > Save.
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Adding a gradient to the background
The gradient tool options let you create straight-line, radial, angle, reflected, and 

diamond blends between colors. You can fill a background or a selection with a gradient.

1 In the Layers palette, select the Gradient layer.

2 Select the gradient tool ( ) hidden under the paint bucket tool ( ).

You’ll make a color gradient that starts with white on the left and gradually blends to 

brown on the right.

3 In the tool options bar, click the gradient sample box to display the Gradient Editor 

dialog box.

The Gradient Editor dialog box lets you define a new gradient by modifying a copy of an 

existing gradient. You can also add intermediate colors to a gradient, creating a blend 

between more than two colors.

4 In the Gradient Editor dialog box, double-click the color stop ( ) located at the lower-

left corner of the gradient bar, to select it and display the Color Picker dialog box.

Double-clicking the color stops below the gradient bar
selects them and displays the Color Picker dialog box.

5 In the Color Picker dialog box, select the white color in the upper-left corner, and click 

the cube icon ( ) to adjust the color to a Web color. 
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Before selecting a color in the Color Picker, you can select Only Web Colors to limit your 

selection to Web-safe colors.

6 Click OK.

7 In the Gradient Editor dialog box, double-click the color stop ( ) located at the lower-

right corner of the gradient bar, to display the Color Picker dialog box again.

8 In the Color Picker dialog box, select the check box for Only Web Colors, and then 

enter 147 in the R text box, 132 in the G text box, and 100 in the B text box.

After you enter each value, Photoshop immediately changes them to the closest Web 

value: 153 for R, 153 for G, and 102 for B.

9 Click OK to close the Color Picker, and then click OK to close the Gradient Editor 

dialog box.

Notice that the brown gradient you created appears in the tool options bar.

10 In the tool options bar, select the Radial Gradient icon ( ).

11 Using the gradient tool, drag from the center of the image to the edge of the document 

window and release the mouse.

Dragging the gradient tool from the center of the flowers
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The white color of the gradient starts at the center and radiates out to brown on all the 

edges of the image. Now you’ll blend the luminosity of the radial gradient with the green 

color of the Background layer.

12 In the Layers palette, choose Luminosity from the menu at the top of the palette to set 

the blending mode for the Gradient layer.

13 Choose File > Save.

Creating a glow effect with a custom airbrush
The airbrush tool paints soft-edged strokes. You can make adjustments in the airbrush 

tool options bar and save them as a custom airbrush for reuse.

1 In the Layers palette, select the Glow layer.

2 Select the airbrush tool ( ).

3 Hold down Alt (Windows) or Option (Mac OS) to change the pointer to an 

eyedropper ( ) and click on a flower petal to sample a light color from it.

The color you sampled appears in the foreground color fill box in the toolbox. Now you’ll 

create a custom airbrush with a large diameter.

4 In the tool options bar, click the Brush Editor button ( ) to the left of the Brush 

arrow.

5 In the Brush Editor pop-up palette, enter 150 in the Diameter text box. Keep the 

Hardness at 0 and Spacing at 25. Then enter Glow Brush in the Name text box. 

6 Click the Create New Preset button ( ) in the upper-right corner of the Brush Editor.

Create New Preset button in the Brush Editor pop-up palette
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Your new custom airbrush now appears in the list of brushes in the tool options bar.

If you have difficulty locating your new custom airbrush in the palette, click the triangle 

in the upper-right corner of the pop-up palette. Choose Small List from the palette menu. 

You can then scroll through a list of brushes and choose your new custom brush option. 

Use the palette menu to choose different configurations for viewing the brushes in the 

pop-up palette.

7 Click with your custom airbrush to paint a glow over the ends of the flowers. 

Click the ends of the flower with your custom airbrush tool.

8 At the top of the Layers palette, enter 80% in the Opacity text box and choose Overlay 

from the menu to set the blending mode for the Glow layer.

9 Choose File > Save.

Creating a textured effect with a natural brush
Now you’ll create a textured effect around the lilies, using a natural brush and applying 

different blending modes for the brush strokes.

Adobe Photoshop comes with bonus items, such as custom shapes and brushes, that you 

can add to your tool palettes. In this section of the lesson, you’ll add natural brushes to 

the airbrush pop-up palette. Natural brushes simulate natural painting tools such as 

chalk, pencils, pens, and watercolors.
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1 In the Layers palette, select the Natural Brush layer.

2 In the tool options bar for the airbrush tool, click the Brush arrow to display the Brush 

pop-up palette and then choose Natural Brushes 2.abr from the palette menu. 

Palette menu in the Brush pop-up palette

3 In the dialog box, click Append to add the natural brushes to the Brush palette.

4 In the Brush palette, select the 118 Pastel Light 120 Pixels brush.

5 In the tool options bar, choose Screen from the Mode menu and enter 50% in the 

Pressure text box.

6 In the toolbox, double-click the Set Foreground Color box ( ) to display the Color 

Picker dialog box.

7 In the Color Picker dialog box, deselect Only Web Colors, and select a dark blue color 

or enter 65 in the R text box, 73 in the G text box, and 157 in the B text box.

8 Using the natural brush, click around the outer perimeter and in the center of the 

flowers to add blocks of color.
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Don’t worry about adding too much blue with the natural brush. You’ll be applying a 

blending mode to the layer, which will cause most of the blue (the blend color) paint 

strokes to disappear and reveal the base color of the image.

Overlaid colors using the natural brush

9 In the tool options bar, choose Color Dodge from the Mode menu.

The Color Dodge blending mode looks at the color information in each channel and 

brightens the base color to reflect the blend color. Blending with black produces no 

change in the Color Dodge mode.

10 Click in the image to add more blocks of brighter color to the center of the flowers.

11 Choose Filter > Noise > Add Noise.

12 In the Add Noise dialog box, enter 10 in the Amount text box, select Gaussian for the 

Distribution, select Monochromatic, and click OK.
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The Noise filters add or remove either pixels or noise (distortions, technically referred to 

as stochastic variations) with randomly distributed color levels. This helps to blend a 

selection into the surrounding pixels. Noise filters can create unusual textures or remove 

problem areas, such as dust and scratches from an image.

13 In the Layers palette, choose Difference from the Blend Mode menu, and

enter 80% in the Opacity text box for the Natural Brush layer.

The amount of blue (the blend color) remaining in the image depends on how much you 

applied with the natural brush in step 8.

The Difference blending mode looks at the color information in each channel and 

subtracts either the blend color from the base color or the base color from the blend color, 

depending on which has the greater brightness value. Blending with white inverts the base 

color values; blending with black produces no change.

14 Choose File > Save.

Creating a patterned border
As mentioned earlier in this lesson, you can fill a layer or selection with a color, texture, 

or pattern. You’ll define a checkered pattern and use the paint bucket tool to paint the 

image border with it.

1 In the Layers palette, select the Pattern_Fill layer.

2 Choose File > Open and open the file Pattern_Check.psd from the Lessons/Lesson04 

folder.

3 Choose Select > All.

4 Choose Edit > Define Pattern.

5 In the Pattern Name dialog box, enter Checkered for the Name and click OK.

6 Close the Pattern_check.psd file.

7 Select the paint bucket tool ( ) hidden under the gradient tool ( ).
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8 In the tool options bar, choose Pattern from the Fill menu. Then click the Pattern 

arrow ( ) to open the Pattern pop-up palette, and select the Checkered pattern you 

defined.

Selecting the Checkered pattern in the Pattern pop-up palette

9 Using the paint bucket tool, click in the 04Start.psd image.

The entire layer is filled with the checkered pattern. Now you’ll use the guides included in 

the start file to help you cut out the central area of the pattern and create the border. 

10 Choose View > Show Extras or View > Show > Guides.

11 Select the rectangular marquee tool ( ) and draw a rectangular marquee over the 

central area of the image that matches up with the guides.

To help you match your selection with the guides, make sure View > Snap To > Guides is 

active.



LESSON 4106
Painting and Editing

12 Choose Edit > Cut.

Selecting with the rectangular marquee tool Selected area cut from the image

13 In the Layers palette, choose Multiply from the Blend Mode menu for the Pattern Fill 

layer.

The Multiply blending mode multiplies the original color of the image by the colors in the 

pattern to give a darker blend.

To view the image without guides showing, choose View > Show Extras or View > Show > 

Guides to hide the guides.

14 Choose File > Save.
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Review questions
1 What is a blending mode, and what are the three types of color that are helpful for 

visualizing a blending mode’s effect?

2 What do the History palette, eraser tool, and history brush tools have in common?

3 What is the difference between the art history brush tool and the history brush tool?

4 Why would you use the smudge tool?

5 How do you prevent layer properties from being changed?

6 Describe what the Gradient Editor dialog box is used for and how you display it.

7 What are noise filters used for?

Review answers
1 A blending mode controls how pixels in an image are affected by the tools or other 

layers. It’s helpful to think in terms of the following colors when visualizing a blending 

mode’s effect:

• The base color is the original color in the image.

• The blend color is the color being applied with the painting or editing tool.

• The result color is the color resulting from the blend.

2 The History palette, eraser tool, and history brush tools can all revert your image to an 

earlier state so you can undo an operation or correct a mistake.

3 The art history brush tool paints with a stylized stroke based on a selected state or 

snapshot. The stylized stroke of the art history brush tool simulates the look of different 

paint styles. The history brush tool paints a copy of the selected state or snapshot into the 

current image window. You can use the history brush tool to remove the strokes made 

with the art history brush tool. 

4 You can use the smudge tool to soften the edges of your paint strokes. The smudge tool 

simulates the actions of dragging a finger through wet paint. The tool picks up color 

where the stroke begins and pushes it in the direction you drag.

5 Locking layers and layer sets makes certain properties of a layer unchangeable. 

You can lock transparent pixels to confine your painting and editing to those areas of a 

layer already containing pixels. You can also lock image pixels and the position of an 

image layer.
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6 The Gradient Editor dialog box lets you define a new gradient by modifying a copy of 

an existing gradient. You can also add intermediate colors to a gradient, creating a blend 

between more than two colors. To display the Gradient Editor dialog box, select the 

gradient tool ( ) and click the gradient sample box in the tool option bar.

7 Noise filters can create unusual textures or remove problem areas, such as dust and 

scratches from an image. The Noise filters add or remove either pixels or noise in an image 

with randomly distributed color levels.
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